const regex = /\b(\d)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d)\\b', 'gm')
const str = `1-05-2019
2-05-2019
15-05-2019
27-05-2019`;
const subst = `0$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);