$re = '/\b(\d)\b/m';
$str = '1-05-2019
2-05-2019
15-05-2019
27-05-2019';
$subst = "0$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;