# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.+\\/)(.+)/[\2](https:\/\/github.com\/qgis\/QGIS\/pull\/\2)/gm;t' <<< " /qgis/QGIS/pull/53256"