// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.+\/)(.+)").unwrap();
let string = " /qgis/QGIS/pull/53256";
let substitution = "[\\2](https://github.com/qgis/QGIS/pull/\\2)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}