import Foundation
let pattern = #"(.+\/)(.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #" /qgis/QGIS/pull/53256"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[\2](https://github.com/qgis/QGIS/pull/\2)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)