re = /(.+\/)(.+)/m
str = ' /qgis/QGIS/pull/53256'
subst = '[\\2](https://github.com/qgis/QGIS/pull/\\2)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result