const regex = /(.+\/)(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+\\\/)(.+)', 'gm')
const str = ` /qgis/QGIS/pull/53256`;
const subst = `[\2](https://github.com/qgis/QGIS/pull/\2)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);