#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.+\/)(.+)"
Local $sString = " /qgis/QGIS/pull/53256"
Local $sSubst = "[\2](https://github.com/qgis/QGIS/pull/\2)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)