$re = '/(.+\/)(.+)/m';
$str = ' /qgis/QGIS/pull/53256';
$subst = "[\2](https://github.com/qgis/QGIS/pull/\2)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;