# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\w+\((?:\w+(?:\s*,\s*\w+)*)?\)/[\d][\d][\d]/gm;t' <<< "Hello, world test(test) testing
Hello, world test(test)test testing
test()
test(a, b)
test(,)
test(,a)"