re = /\w+\((?:\w+(?:\s*,\s*\w+)*)?\)/m
str = 'Hello, world test(test) testing
Hello, world test(test)test testing
test()
test(a, b)
test(,)
test(,a)'
subst = '[\\d][\\d][\\d]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result