const regex = /\w+\((?:\w+(?:\s*,\s*\w+)*)?\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+\\((?:\\w+(?:\\s*,\\s*\\w+)*)?\\)', 'gm')
const str = `Hello, world test(test) testing
Hello, world test(test)test testing
test()
test(a, b)
test(,)
test(,a)`;
const subst = `[\d][\d][\d]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);