import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+\\((?:\\w+(?:\\s*,\\s*\\w+)*)?\\)";
final String string = "Hello, world test(test) testing\n"
+ "Hello, world test(test)test testing\n"
+ "test()\n"
+ "test(a, b)\n"
+ "test(,)\n"
+ "test(,a)";
final String subst = "[\\d][\\d][\\d]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}