import Foundation
let pattern = #"\w+\((?:\w+(?:\s*,\s*\w+)*)?\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Hello, world test(test) testing
Hello, world test(test)test testing
test()
test(a, b)
test(,)
test(,a)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[\d][\d][\d]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)