import re
regex = re.compile(r"\w+\((?:\w+(?:\s*,\s*\w+)*)?\)", flags=re.MULTILINE)
test_str = ("Hello, world test(test) testing\n"
"Hello, world test(test)test testing\n"
"test()\n"
"test(a, b)\n"
"test(,)\n"
"test(,a)")
subst = "[\\d][\\d][\\d]"
result = regex.sub(subst, test_str)
if result:
print(result)