package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+\((?:\w+(?:\s*,\s*\w+)*)?\)`)
var str = `Hello, world test(test) testing
Hello, world test(test)test testing
test()
test(a, b)
test(,)
test(,a)`
var substitution = "[\d][\d][\d]"
fmt.Println(re.ReplaceAllString(str, substitution))
}