$re = '/\w+\((?:\w+(?:\s*,\s*\w+)*)?\)/m';
$str = 'Hello, world test(test) testing
Hello, world test(test)test testing
test()
test(a, b)
test(,)
test(,a)';
$subst = "[\d][\d][\d]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;