#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\w+\((?:\w+(?:\s*,\s*\w+)*)?\)"
Local $sString = "Hello, world test(test) testing" & @CRLF & _
"Hello, world test(test)test testing" & @CRLF & _
"test()" & @CRLF & _
"test(a, b)" & @CRLF & _
"test(,)" & @CRLF & _
"test(,a)"
Local $sSubst = "[\d][\d][\d]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)