# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*(https?:\\/\\/\S+)\s*/\n$1\n/gm;t' <<< "hello world, testing https://stackoverflow.com/questions/ask this is prefix https://gmail.com final text"