// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*(https?:\/\/\S+)\s*").unwrap();
let string = "hello world, testing https://stackoverflow.com/questions/ask this is prefix https://gmail.com final text";
let substitution = "\\n$1\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}