re = /\s*(https?:\/\/\S+)\s*/m
str = 'hello world, testing https://stackoverflow.com/questions/ask this is prefix https://gmail.com final text'
subst = '\\n$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result