const regex = /\s*(https?:\/\/\S+)\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(https?:\\\/\\\/\\S+)\\s*', 'gm')
const str = `hello world, testing https://stackoverflow.com/questions/ask this is prefix https://gmail.com final text`;
const subst = `\n$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);