import Foundation
let pattern = #"\s*(https?:\/\/\S+)\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"hello world, testing https://stackoverflow.com/questions/ask this is prefix https://gmail.com final text"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n$1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)