use strict;
my $str = 'hello world, testing https://stackoverflow.com/questions/ask this is prefix https://gmail.com final text';
my $regex = qr/\s*(https?:\/\/\S+)\s*/mp;
my $subst = '\\n$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";