using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(https?:\/\/\S+)\s*";
string substitution = @"\n$1\n";
string input = @"hello world, testing https://stackoverflow.com/questions/ask this is prefix https://gmail.com final text";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}