package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*(https?:\/\/\S+)\s*`)
var str = `hello world, testing https://stackoverflow.com/questions/ask this is prefix https://gmail.com final text`
var substitution = "\n$1\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}