$re = '/\s*(https?:\/\/\S+)\s*/m';
$str = 'hello world, testing https://stackoverflow.com/questions/ask this is prefix https://gmail.com final text';
$subst = "\n$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;