#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*(https?:\/\/\S+)\s*"
Local $sString = "hello world, testing https://stackoverflow.com/questions/ask this is prefix https://gmail.com final text"
Local $sSubst = "\n$1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)