# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\((.+)\)(\d+)|\[(.+)\](\d+)|\{(.+)\}(\d+))/this/gm;t' <<< "Fe(NO3)2
H2O
Mg(OH)2
K4[ON(SO3)2]2
K4{ON(SO3)2}2
"