import re
regex = re.compile(r"(\((.+)\)(\d+)|\[(.+)\](\d+)|\{(.+)\}(\d+))", flags=re.MULTILINE)
test_str = ("Fe(NO3)2\n"
"H2O\n"
"Mg(OH)2\n"
"K4[ON(SO3)2]2\n"
"K4{ON(SO3)2}2\n")
subst = "this"
result = regex.sub(subst, test_str)
if result:
print(result)