#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\((.+)\)(\d+)|\[(.+)\](\d+)|\{(.+)\}(\d+))"
Local $sString = "Fe(NO3)2" & @CRLF & _
"H2O" & @CRLF & _
"Mg(OH)2" & @CRLF & _
"K4[ON(SO3)2]2" & @CRLF & _
"K4{ON(SO3)2}2" & @CRLF & _
""
Local $sSubst = "this"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)