// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\((.+)\)(\d+)|\[(.+)\](\d+)|\{(.+)\}(\d+))").unwrap();
let string = "Fe(NO3)2
H2O
Mg(OH)2
K4[ON(SO3)2]2
K4{ON(SO3)2}2
";
let substitution = "this";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}