use strict;
my $str = 'Fe(NO3)2
H2O
Mg(OH)2
K4[ON(SO3)2]2
K4{ON(SO3)2}2
';
my $regex = qr/(\((.+)\)(\d+)|\[(.+)\](\d+)|\{(.+)\}(\d+))/mp;
my $subst = 'this';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";