using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\((.+)\)(\d+)|\[(.+)\](\d+)|\{(.+)\}(\d+))";
string substitution = @"this";
string input = @"Fe(NO3)2
H2O
Mg(OH)2
K4[ON(SO3)2]2
K4{ON(SO3)2}2
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}