package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\((.+)\)(\d+)|\[(.+)\](\d+)|\{(.+)\}(\d+))`)
var str = `Fe(NO3)2
H2O
Mg(OH)2
K4[ON(SO3)2]2
K4{ON(SO3)2}2
`
var substitution = "this"
fmt.Println(re.ReplaceAllString(str, substitution))
}