re = /(\((.+)\)(\d+)|\[(.+)\](\d+)|\{(.+)\}(\d+))/m
str = 'Fe(NO3)2
H2O
Mg(OH)2
K4[ON(SO3)2]2
K4{ON(SO3)2}2
'
subst = 'this'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result