# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d+)\h+([a-z]+)\h+(\d+)(?:\R\S*$)*/$1;$2;$3/gm;t' <<< "1 foo 745
2 baz 746
ga1rbag
morehere"