re = /^(\d+)\h+([a-z]+)\h+(\d+)(?:\R\S*$)*/m
str = '1 foo 745
2 baz 746
ga1rbag
morehere'
subst = '$1;$2;$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result