// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+)\h+([a-z]+)\h+(\d+)(?:\R\S*$)*").unwrap();
let string = "1 foo 745
2 baz 746
ga1rbag
morehere";
let substitution = "$1;$2;$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}