const regex = /^(\d+)\h+([a-z]+)\h+(\d+)(?:\R\S*$)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+)\\h+([a-z]+)\\h+(\\d+)(?:\\R\\S*$)*', 'gm')
const str = `1 foo 745
2 baz 746
ga1rbag
morehere`;
const subst = `$1;$2;$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);