#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d+)\h+([a-z]+)\h+(\d+)(?:\R\S*$)*"
Local $sString = "1 foo 745" & @CRLF & _
"2 baz 746" & @CRLF & _
"ga1rbag" & @CRLF & _
"morehere"
Local $sSubst = "$1;$2;$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)