import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+)\\h+([a-z]+)\\h+(\\d+)(?:\\R\\S*$)*";
final String string = "1 foo 745\n"
+ "2 baz 746\n"
+ "ga1rbag\n"
+ "morehere";
final String subst = "$1;$2;$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}