$re = '/^(\d+)\h+([a-z]+)\h+(\d+)(?:\R\S*$)*/m';
$str = '1 foo 745
2 baz 746
ga1rbag
morehere';
$subst = "$1;$2;$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;