using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+)\h+([a-z]+)\h+(\d+)(?:\R\S*$)*";
string substitution = @"$1;$2;$3";
string input = @"1 foo 745
2 baz 746
ga1rbag
morehere";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}