use strict;
my $str = '1 foo 745
2 baz 746
ga1rbag
morehere';
my $regex = qr/^(\d+)\h+([a-z]+)\h+(\d+)(?:\R\S*$)*/mp;
my $subst = '$1;$2;$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";