import Foundation
let pattern = #"^(\d+)\h+([a-z]+)\h+(\d+)(?:\R\S*$)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1 foo 745
2 baz 746
ga1rbag
morehere
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1;$2;$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)