using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?sx)
Container\(""\w+""\)\.(?:TextCtrls|LabelCtrls)\(""(?<ControlName>\w+)""\).Text";
string substitution = @"\1\2";
string input = @"Container(""Name1"").TextCtrls(""Name2"").Text
Container(""Name1"").LabelCtrls(""Name2"").Text";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}