import Foundation
let pattern = #"""
(?sx)
Container\("\w+"\)\.(?:TextCtrls|LabelCtrls)\("(?<ControlName>\w+)"\).Text
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.allowCommentsAndWhitespace, .dotMatchesLineSeparators])
let testString = #"""
Container("Name1").TextCtrls("Name2").Text
Container("Name1").LabelCtrls("Name2").Text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)