import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?sx)\n"
+ "Container\\(\"\\w+\"\\)\\.(?:TextCtrls|LabelCtrls)\\(\"(?<ControlName>\\w+)\"\\).Text";
final String string = "Container(\"Name1\").TextCtrls(\"Name2\").Text\n"
+ "Container(\"Name1\").LabelCtrls(\"Name2\").Text";
final String subst = "\\1\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}