use strict;
my $str = 'Container("Name1").TextCtrls("Name2").Text
Container("Name1").LabelCtrls("Name2").Text';
my $regex = qr/(?sx)
Container\("\w+"\)\.(?:TextCtrls|LabelCtrls)\("(?<ControlName>\w+)"\).Text/sxp;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";